Payments to the tax authorities are not working.
Incident Report for InformerOnline
Resolved
This incident has been resolved!
Posted Apr 12, 2021 - 14:28 CEST
Investigating
We are currently investigating why the payments to the tax authorities are not working.
Posted Feb 17, 2021 - 08:59 CET